Home > Not Working > 2000 Nissan Xterra Gauges Not Working

2000 Nissan Xterra Gauges Not Working


I thought maybe it was worn/dirty contacts on the back of the cluster, but if it's still getting power for lighting, I dunno how that could be. If it was mechanical all three of those things wouldn't be related and wouldn't occur together...So what was it? Is that right? If I throw it in neutral and rev it once, it stops doing it and runs fine. have a peek here

Real Name: quinn Year: 2011 Model: S Color: K12 - Radiant Silver Transmission: CVT Mileage: 50,000 Join Date: Jul 2010 Official Member #: 330 Last Online: 10-04-2015 04:55 PM Thanks for your input Did you remove the screw that holds the assembly in place before you tried to remove it? I realized that my tachometer still works, and luckily I have a manual 4x4 so I am able to guesstimate my speed based on what gear I am in and the I need help. http://www.clubxterra.org/forums/archive/index.php/t-16955.html

Nissan Xterra Speedometer Not Working

That could cause the same poor grounding situation, no? Should I buy a new VSS or is it a fuse problem? Should I be concerned and what is the cause of this? We changed the speed sensor and it did nothing.

The unit will retain its programming and mileage! my6thgen.org Profile Info. Fuse. __________________ '04 SE 6MT, Elite. '01 SE Anniversary. '97 GXE. -=My Build Tread=-http://my6thgen.org/f13/danski6mts-e...revival-15837/ 01-22-2013, 02:49 AM #12 Teazy120 Newbie my6thgen.org Profile Info. 2000 Nissan Frontier Instrument Cluster Problems This morning they were working fine, but on the way home from work it started again.

mrwhizard08-10-2012, 07:07 AMCommon problem with these and other 2000 Nissan Models including Frontier, Altima. I have a 2000 Nissan Xterra. Three months later - still no luck. More Help Our hours of operation are 9:00AM to 6:00PM Monday-Friday (Arizona Mountain Time) Please contact us @ (480) 464-ASAP (2727)… Our professional staff will be happy to assist you and answer all

So basically it's specific to dash gauges (not dash lights), auto steering wheel going into place, Heat/AC not coming on, interior blinkers not blinking in dash. Nissan Pathfinder Speedometer Not Working Nissan Xterra - Maintenance & Repair My '04 xterra has 49,155 miles on it and the check engine light came on, is that for a 50,000 mile tune up? 2 answers Lost the speedo, RPMs, gas & temperature. WE WILL BENCH TEST THE GAUGE CLUSTER TO MAKE SURE IT IS WORKING PROPERLY.

2000 Nissan Xterra Instrument Cluster

You might wanna check to see if the accelerator and that section of the engine is fine, simply because all three of those (tach, speed, and gas) dont respond all at http://forums.edmunds.com/discussion/8081/nissan/xterra/nissan-xterra-gauges The car normally runs well.But occassionally (maybe once a month), the speedometer & odometer both stop working while driving down the road. Nissan Xterra Speedometer Not Working We have repaired thousands of these units and we offer a LIFETIME GUARANTEE on all of the units we repair! (Note: Lifetime Warranty does not apply to bulbs. 2000 Nissan Frontier Speedometer Not Working Did I pop the dash fuse?

A…When we repair the units. navigate here It couldn't come off no matter how hard I pulled...SO I just took my car to the shop...On my way to the shop..the VSS didnt work...I plugged it in before I mattpramschufer View Public Profile Send a private message to mattpramschufer Find all posts by mattpramschufer Visit mattpramschufer photo album Bookmarks Facebook Digg del.icio.us StumbleUpon Tags 2000, failure, gauges, spedometer, xterra « Whizard, June 20, 2013Common problem with these clusters. Nissan Frontier Speed Sensor

You currently have 0 posts. Any help is appreciated. The car will not accelerate and is now slowing down in the fast lane. Check This Out The engine will start kicking on an off until you reach 0mph.

Do you happen to remember which panel you found it in, there are three different fuse boxes I believe. Nissan Xterra Instrument Cluster Removal I have no problem changing oil and whatnot myself, but i've never touched a trans and am a little worrisome i'd eff something up. Anyway after testing with a volt meter i decided to buy a new gauge cluster on ebay.

There is a fix for them.

But we'll see. If anyone else has suggestions, I'd appreciate them. I have a bluetooth engine scanner and I plugged it in and got no speed reading but got all the other parameters. Nissan Sentra Speedometer Not Working After waiting about 5 minutes the guages come back on and all appears normal.

and after a while of driving around with the lights on and the dimmer in full brightness. But once this starts during a driving trip, it keeps repeating the off/on pattern until I park the car for a while. Thread Tools 06-01-2011, 01:12 PM Thread Starter #1 jblack76 Newbie my6thgen.org Profile Info. this contact form I hope this helps someone!

certain speeds/hitting bumps/etc) nor does there seem to be any rhyme or reason to when it comes back to life (ie. In the meantime, I noticed someone had posted a "workaround" of turning the cluster illumination dimmer down.